Windows support


#1

A student trying to develop picos from windows is having trouble. He explained to me,
I have node and npm installed on my computer, I updated them and then ran npm install -g pico-engine' which installed properly. Then when I runpico-engine` I get an error “Error: $1 is not a valid Win32 application” so I can’t actually run the pico-engine. Is there something I’m missing or something I can try?
Has anyone set pico-engine up in windows, or have any advice to share?


#2

I just installed it on a windows 7 box and it ran just fine. I also started a windows CI build https://ci.appveyor.com/project/farskipper/node-pico-engine-core testing 32bit and 64bit windows

Have them try running it in the “Node.js command prompt” not to be confused with the node repl.

If that doesn’t work can you send me the windows version and
npm -v
node -v


#3

I am that student. I tried running those commands in Bash on Windows and it worked perfectly. I’m not sure why it didn’t work when I tried running pico-engine in PowerShell but I can do everything I need with it running in Bash.